2017-12-17 18 views
0

npm run dev 명령을 실행하면이 오류가 발생합니다. 여러 번 시도하여 web3의 다양한 버전을 설치하고 트러플 계약을 해봤지만 매번 같은 오류가 발생합니다 .모듈을 찾을 수 없습니다 : web3가 트뤼플 계약서를 해결할 수 없습니다

정확한 오류 :이 전 세계적으로 설치하려고 작동하지 않을 경우

ERROR in ./app/javascripts/app.js 
Module not found: Error: Can't resolve 'truffle-contract' in 'C:\Users\Siddharth\Desktop\SID\ALSC\PROJECT\asset-lending\app\javascripts' 
@ ./app/javascripts/app.js 6:1-55 
@ multi (webpack)-dev-server/client?http://localhost:8080 ./app/javascripts/app.js 

ERROR in ./app/javascripts/app.js 
Module not found: Error: Can't resolve 'web3' in 'C:\Users\Siddharth\Desktop\SID\ALSC\PROJECT\asset-lending\app\javascripts' 
@ ./app/javascripts/app.js 5:1-39 
@ multi (webpack)-dev-server/client?http://localhost:8080 ./app/javascripts/app.js 
webpack: Failed to compile. 

답변

0

NPM, 그것은 사람들이 오류를 해결 트 뤼프 계약을 설치, 내 경우에는 내가 로컬로 설치.

https://www.npmjs.com/package/truffle-contract

+0

나는 로컬 및 전 세계적으로 모두 시도했지만 여전히이 같은 오류를 제공합니다 –